华为金牌代理商_光纤光缆_光纤跳线_网络布线设备_安防线材-广州市宇川网络科技有限公司

行业动态


     
    华为交换机三种划分vlan的方法

     

    在学习划分vlan前,必须要了解华为交换机的端口类型:

    Access类型端口

    执行命令port default vlan vlan-id,将端口加入到指定的VLAN中。如果需要批量将端口加入VLAN,可在VLAN视图下执行命令port interface-type { interface-number1 [ to interface-number2 ] } &向VLAN中添加一个或一组端口。

     

    Trunk类型端口

    – 执行命令port trunk allow-pass vlan { { vlan-id1 [ to vlan-id2 ] } &| all },将端口加入到指定的VLAN中。
    –(可选)执行命令port trunk pvid vlan vlan-id,配置Trunk类型接口的缺省VLAN。


    Hybrid类型端口

    – 选择执行其中一个步骤配置Hybrid端口加入VLAN的方式:
    – 执行命令port hybrid untagged vlan { { vlan-id1 [ to vlan-id2 ] } &| all },将Hybrid端口以Untagged方式加入VLAN。Untagged形式是指端口在发送帧时会将帧中的Tag剥掉,适用于以太网端口直接与终端连接。
    – 执行命令port hybrid tagged vlan { { vlan-id1 [ to vlan-id2 ] } &| all },将Hybrid端口以Tagged方式加入VLAN。Tagged形式是指端口在发送帧时不将帧中的Tag剥掉,适用于以太网端口与另一台交换机设备的端口连接。


    –(可选)执行命令port hybrid pvid vlan vlan-id,配置Hybrid类型接口的缺省VLAN ID。

    缺省情况下,所有端口加入的VLAN和缺省VLAN都是VLAN1。

     

    一、基于端口的vlan

    组网需求
    如图1所示,某企业的交换机连接有很多用户,且相同业务用户通过不同的设备接入企业网络。为了通信的安全性,也为了避免广播报文泛滥,企业希望业务相同用户之间可以互相访问,业务不同用户不能直接访问。
    可以在交换机上配置基于端口划分VLAN,把业务相同的用户连接的端口划分到同一VLAN。这样属于不同VLAN的用户不能直接进行二层通信,同一VLAN内的用户可以直接互相通信。

     

     

    操作步骤

    步骤1 在SwitchA创建VLAN2和VLAN3,并将连接用户的端口分别加入VLAN。SwitchB配置与SwitchA类似,不再赘述。
    system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 2 3
    [SwitchA] interface ethernet 0/0/1
    [SwitchA-Ethernet0/0/1] port link-type access
    [SwitchA-Ethernet0/0/1] port default vlan 2
    [SwitchA-Ethernet0/0/1] quit
    [SwitchA] interface ethernet 0/0/2
    [SwitchA-Ethernet0/0/2] port link-type access
    [SwitchA-Ethernet0/0/2] port default vlan 3
    [SwitchA-Ethernet0/0/2] quit

    步骤2 配置SwitchA上与SwitchB连接的端口类型及通过的VLAN。SwitchB配置与SwitchA类似,不再赘述。

    [SwitchA] interface ethernet 0/0/3
    [SwitchA-Ethernet0/0/3] port link-type trunk
    [SwitchA-Ethernet0/0/3] port trunk allow-pass vlan 2 3

    步骤3 验证配置结果将User1和User2配置在一个网段,比如192.168.100.0/24;将User3和User4配置在一个网段,比如192.168.200.0/24。

    User1和User2能够互相ping通,但是均不能ping通User3和User4。User3和User4能够互相ping通,但是均不能ping通User1和User2。

     

     

     二、基于MAC地址划分Vlan

    组网需求
    某个公司的网络中,网络管理者将同一部门的员工划分到同一VLAN。为了提高部门内的信息安全,要求只有本部门员工的PC才可以访问公司网络。如图2所示,PC1、PC2、PC3为本部门员工的PC,要求这几台PC可以通过SwitchA、Switch访问公司网络,如换成其他PC则不能访问。可以配置基于MAC地址划分VLAN,将本部门员工PC的MAC地址与VLAN绑定,从而实现该需求。

     

    操作步骤

    步骤1 配置Switch

    # 创建VLAN
    system-view
    [Quidway] vlan batch 10 100


    # 配置接口的PVID和加入VLAN
    [Quidway] interface ethernet 0/0/1
    [Quidway-Ethernet0/0/1] port hybrid pvid vlan 100
    [Quidway-Ethernet0/0/1] port hybrid untagged vlan 10
    [Quidway-Ethernet0/0/1] quit
    [Quidway] interface ethernet 0/0/2
    [Quidway-Ethernet0/0/2] port hybrid tagged vlan 10
    [Quidway-Ethernet0/0/2] quit


    # PC的MAC地址与VLAN10关联
    [Quidway] vlan 10
    [Quidway-Vlan10] mac-vlan mac-address 22-22-22
    [Quidway-Vlan10] mac-vlan mac-address 33-33-33
    [Quidway-Vlan10] mac-vlan mac-address 44-44-44
    [Quidway-Vlan10] quit


    # 使能接口的基于MAC地址划分VLAN功能
    [Quidway] interface ethernet 0/0/1
    [Quidway-Ethernet0/0/1] mac-vlan enable
    [Quidway-Ethernet0/0/1] quit

     

    三、基于IP子网的Vlan划分

    组网需求

    某企业拥有多种业务,如IPTV、VoIP、Internet等,每种业务使用的IP地址网段各不相同。为了便于管理,现需要将同一种类型业务划分到同一VLAN中,不同类型的业务划分到不同VLAN中。如图3所示,Switch接收到用户报文有数据、IPTV、语音等多种业务,用户设备的IP地址网段各不相同。现需要将不同类型的业务划分到不同的VLAN中,通过不同的VLANID分流到不同的远端服务器上以实现业务互通。

     

     

    配置思路

    采用如下的思路配置基于IP子网划分VLAN:
    1. 创建VLAN,确定每种业务所属的VLAN。
    2. 关联IP子网和VLAN,实现根据报文中的源IP地址或指定网段确定VLAN。
    3. 配置端口加入VLAN,实现基于IP子网的VLAN通过当前端口。
    4. 配置VLAN划分方式的优先级,确保优先选择基于IP子网划分VLAN。
    5. 使能基于IP子网划分VLAN。

     

    操作步骤

    步骤1 创建VLAN
    # 在Switch上创建VLAN100、VLAN200和VLAN300。
    system-view
    [Quidway] vlan batch 100 200 300


    步骤2 配置接口
    # 在Switch上配置接口Eth0/0/1为Hybrid类型,并加入VLAN100、VLAN200和VLAN300。
    [Quidway] interface ethernet 0/0/1
    [Quidway-Ethernet0/0/1] port link-type hybrid
    [Quidway-Ethernet0/0/1] port hybrid untagged vlan 100 200 300
    [Quidway-Ethernet0/0/1] quit
    # 在Switch上配置接口Eth0/0/2加入VLAN100。
    [Quidway] interface ethernet 0/0/2
    [Quidway-Ethernet0/0/2] port link-type trunk
    [Quidway-Ethernet0/0/2] port trunk allow-pass vlan 100
    [Quidway-Ethernet0/0/2] quit
    # 在Switch上配置接口Eth0/0/3加入VLAN200。
    [Quidway] interface ethernet 0/0/3
    [Quidway-Ethernet0/0/3] port link-type trunk
    [Quidway-Ethernet0/0/3] port trunk allow-pass vlan 200
    [Quidway-Ethernet0/0/3] quit
    # 在Switch上配置接口Eth0/0/4加入VLAN300。
    [Quidway] interface ethernet 0/0/4
    [Quidway-Ethernet0/0/4] port link-type trunk
    [Quidway-Ethernet0/0/4] port trunk allow-pass vlan 300
    [Quidway-Ethernet0/0/4] quit
    # 在Switch上配置接口Eth0/0/1使能基于IP子网划分VLAN功能。
    [Quidway] interface ethernet 0/0/1
    [Quidway-Ethernet0/0/1] ip-subnet-vlan enable
    [Quidway-Ethernet0/0/1] quit


    步骤3 配置基于IP子网划分VLAN
    # 在Switch上配置VLAN100与IP地址192.168.1.2/24关联,优先级为2。
    [Quidway] vlan 100
    [Quidway-vlan100] ip-subnet-vlan 1 ip 192.168.1.2 24 priority 2
    [Quidway-vlan100] quit
    # 在Switch上配置VLAN200与IP地址192.168.2.2/24关联,优先级为3。
    [Quidway] vlan 200
    [Quidway-vlan200] ip-subnet-vlan 1 ip 192.168.2.2 24 priority 3
    [Quidway-vlan200] quit
    # 在Switch上配置VLAN300与IP地址192.168.3.2/24关联,优先级为4。
    [Quidway] vlan 300
    [Quidway-vlan300] ip-subnet-vlan 1 ip 192.168.3.2 24 priority 4
    [Quidway-vlan300] quit


    步骤4 验证配置结果
    在Switch上执行以下命令,显示信息如下:
    [Quidway] display ip-subnet-vlan vlan all
    ----------------------------------------------------------------
    Vlan Index IpAddress SubnetMask Priority
    ----------------------------------------------------------------
    100 1 192.168.1.2 255.255.255.0 2
    200 1 192.168.2.2 255.255.255.0 3
    300 1 192.168.3.2 255.255.255.0 4
    ----------------------------------------------------------------
    ip-subnet-vlan count: 3 total count: 3










  • 产品中心
  • 方案与案例
  • 资讯中心
  • 服务支持
  • 关于宇川
  • 品质宇川
  • 关注我们
  • 宇川官方微信
  • 400-886-3356
  • 17770530568

版权所有-- 广州市宇川网络科技有限公司